Videoconferennce Module in Getting Started

these both fail seemingly due to no login to ci.linagora DOT com:

  1. git clone ci.linagora.com/linagora/lgs/openpaas/linagora.esn.videoconference DOT git
    and
  2. git clone ci.linagora.com/linagora/lgs/openpaas/linagora.esn.videoconference.calendar DOT git

anyone have a remedy or suggestion?

Hello gkondrach,

You can find our repos on github : https://github.com/linagora/linagora.esn.videoconference and https://github.com/linagora/linagora.esn.videoconference.calendar

Regards,
Fabien

2 Likes

Thanks, Fabien.

BTW, I’ve requested a quote from Linagora for paid work. I’ve followed up with messages to various Linagora execs via LinkedIn messaging. No response from any channel.

Can you direct me to someone there who is interested … or at least whose job it is to screen and reject potential customers?

George

Hello @gkondrach,

Sorry for that, really. I am currently looking at the right contact in Linagora to follow your request and will come back to you as soon as possible with more information.

While waiting for this, did you look at the solution suggested by @Fabien_Moyon?

hey help this problem
linagora.esn.videoconference]# npm install
npm WARN deprecated circular-json@0.5.1: CircularJSON is in maintenance only, flatted is its successor.
npm WARN deprecated bcrypt-nodejs@0.0.3: bcrypt-nodejs is no longer actively maintained. Please use bcrypt or bcryptjs. See https://github.com/kelektiv/node.bcrypt.js/wiki/bcrypt-vs-brypt.js to learn more about these two options
npm WARN deprecated email-templates@2.7.1: Please upgrade to email-templates@6.0.0+ as we have significantly improved rendering performance (now occurs in parallel versus serially), and there is only one breaking change with ‘preview’ option, see https://github.com/niftylettuce/email-templates\#v600 and https://github.com/niftylettuce/preview-email\#custom-preview-template-and-stylesheets
npm WARN deprecated mailparser@0.6.1: Mailparser versions older than v2.3.0 are deprecated
npm WARN deprecated mongodb@2.2.9: Please upgrade to 2.2.19 or higher
npm WARN deprecated nodemailer@2.6.0: All versions below 4.0.1 of Nodemailer are deprecated. See https://nodemailer.com/status/
npm WARN deprecated fs-promise@0.4.1: Use mz or fs-extra^3.0 with Promise Support
npm WARN deprecated bower@1.7.9: This Bower version has SECURITY BUG THAT ALLOWS TO WRITE TO ARBITRARY FILE ON YOUR COMPUTER when you install malicious package. Please upgrade Bower to at least version 1.8.8 if you don’t want to get hacked. More info: https://snyk.io/blog/severe-security-vulnerability-in-bowers-zip-archive-extraction/
npm WARN deprecated hawk@3.1.3: This module moved to @hapi/hawk. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm WARN deprecated hoek@2.16.3: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated cryptiles@2.0.5: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated boom@2.10.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated sntp@1.0.9: This module moved to @hapi/sntp. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
npm WARN deprecated mimelib@0.2.19: This project is unmaintained
npm WARN deprecated socks@1.1.9: If using 2.x branch, please upgrade to at least 2.1.6 to avoid a serious bug with socket data flow and an import issue introduced in 2.1.0
npm WARN deprecated mailcomposer@3.12.0: This project is unmaintained
npm WARN deprecated buildmail@3.10.0: This project is unmaintained

canvas@1.6.13 install /root/linagora.esn.videoconference/node_modules/canvas
node-gyp rebuild

Package cairo was not found in the pkg-config search path.
Perhaps you should add the directory containing cairo.pc' to the PKG_CONFIG_PATH environment variable No package 'cairo' found gyp: Call to './util/has_lib.sh freetype' returned exit status 0 while in binding.gyp. while trying to load binding.gyp gyp ERR! configure error gyp ERR! stack Error:gyp` failed with exit code: 1
gyp ERR! stack at ChildProcess.onCpExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:351:16)
gyp ERR! stack at emitTwo (events.js:126:13)
gyp ERR! stack at ChildProcess.emit (events.js:214:7)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:198:12)
gyp ERR! System Linux 3.10.0-1062.9.1.el7.x86_64
gyp ERR! command “/usr/bin/node” “/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “rebuild”
gyp ERR! cwd /root/linagora.esn.videoconference/node_modules/canvas
gyp ERR! node -v v8.17.0
gyp ERR! node-gyp -v v5.0.5
gyp ERR! not ok
npm WARN notsup Unsupported engine for linagora-rse@1.7.0-dev: wanted: {“node”:">= 10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora-rse@1.7.0-dev
npm WARN notsup Unsupported engine for linagora.esn.contact.collect@1.6.0-dev: wanted: {“node”:">= 10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.contact.collect@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.dav.import@1.6.0-dev: wanted: {“node”:">= 10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.dav.import@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.lemonldap@1.6.0-dev: wanted: {“node”:">= 10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.lemonldap@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.group@1.6.0-dev: wanted: {“node”:">= 10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.group@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.linshare@1.6.0-dev: wanted: {“node”:">=10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.linshare@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.james@1.6.0-dev: wanted: {“node”:">= 10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.james@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.resource@1.6.0-dev: wanted: {“node”:">=10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.resource@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.admin@1.6.0-dev: wanted: {“node”:">=10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.admin@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.unifiedinbox.social@1.6.0-dev: wanted: {“node”:">=10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.unifiedinbox.social@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.unifiedinbox.twitter@1.6.0-dev: wanted: {“node”:">=10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.unifiedinbox.twitter@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.chat@1.6.0-dev: wanted: {“node”:">=10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.chat@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.unifiedinbox.james@1.6.0-dev: wanted: {“node”:">=10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.unifiedinbox.james@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.unifiedinbox.linshare@1.6.0-dev: wanted: {“node”:">=10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.unifiedinbox.linshare@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.unifiedinbox@1.6.0-dev: wanted: {“node”:">=10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.unifiedinbox@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.sync@1.6.0-dev: wanted: {“node”:">= 10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.sync@1.6.0-dev
npm WARN notsup Unsupported engine for linagora.esn.calendar@1.6.0-dev: wanted: {“node”:">=10.12.0"} (current: {“node”:“8.17.0”,“npm”:“6.13.4”})
npm WARN notsup Not compatible with your version of node/npm: linagora.esn.calendar@1.6.0-dev
npm WARN acorn-jsx@5.1.0 requires a peer of acorn@^6.0.0 || ^7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-config-airbnb-base@8.0.0 requires a peer of eslint@^3.6.0 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-config-airbnb-base@8.0.0 requires a peer of eslint-plugin-import@^1.16.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.2 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.2: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! canvas@1.6.13 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the canvas@1.6.13 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2019-12-30T04_20_00_545Z-debug.log