Unable to setup and run openpaas release version in ubuntu


#1

Hi ,
I am trying setup openpaas development on ubuntu system,
following develop.md
i am able to run openpaas locally with docker-compose.yml
i am starting openpass supporting softwares in docker with below command

	ESN_HOST="172.17.0.1" ESN_PATH="$PWD" docker-compose -f ./docker/dockerfiles/dev/docker-compose.yml up 

then i run openpass

    npm install

and then run with command

    grunt dev

i get login page But after logging , i am getting blank screen. I can see error in chrome console. as in below snap, How can i setup locally and run openpass , Please Help


.

In documentation i can see front end is vue.js , any changes i need to do here?


#2

Hello @rambhandare101

Did you run bower install?


#3

Hi @tuanlc ,
Thankyou for you response.
i am facing same issue, yes i did bower install. still i get above same error.
how can i get it running.

my issue as in stackoverflow .


#4

Humm, weird,
I followed you reproduce steps but it works.

I answered in the stackoverflow issue that can you remove node_modules and frontend/components and run npm install && bower install again.

If you still get the error. Can you send me full error information by click to the error link in brower console until get the plain text of error? Thanks!