OpenPaas user issue after installation


#1

Hi Team,

I have installed openpaas suite on the server using the docker image. We are able to login into it but after installing we are not able to access all the features available in the suite like calendar,mail.

I have used http://docs.open-paas.org/getting-started/docker/ for installing openpaas. after login when I take pointer over the username it shows me error like, " your user is currently unavailable, you can click and retry"

Is there any thing like I need to create user via any command or do I need to do any database entry in users?

Please guide.

Thanks.


#2

Hello Dushyant_Gohil,
Welcome to our forum and thanks for your question! User accounts are stored on MongoDB. You could try to do the following:

  1. Move to the directory OpenPaaS is installed (for example: var/esn/)
  2. Then, you can type the following command, which will (re)populate MongoDB and hopefully allow you to login again or make at least one user available.
    $ node ./bin/cli populate
    By default, an admin account "admin@open-paas.org" with password “secret” is created.

You can find more information on the command line here:

Hope it helps,


#3

I have followed the steps which are mentioned but still issue is same. I have also attached a screenshot of that kindly check.

Capture


#4

Hi Team,

I am also facing the same issue. I have cloned the source code(git clone https://github.com/linagora/openpaas-esn.git) and follow the docker installation steps (https://github.com/linagora/openpaas-esn/blob/master/docker/doc/install.md). OpenPaas up and running on my local system. I have installed OpenPaas on ubuntu 16.04.

I am getting an error on the console when I login with "admin@open-paas.org" with password “secret”.

error: Can not generate the JWT Error: No “jwt” configuration has been found
at /var/esn/openpaas-esn/backend/core/auth/jwt.js:27:23
at /var/esn/openpaas-esn/backend/core/esn-config/core.js:21:7
at _fulfilled (/var/esn/openpaas-esn/node_modules/q/q.js:854:54)
at self.promiseDispatch.done (/var/esn/openpaas-esn/node_modules/q/q.js:883:30)
at Promise.promise.promiseDispatch (/var/esn/openpaas-esn/node_modules/q/q.js:816:13)
at /var/esn/openpaas-esn/node_modules/q/q.js:624:44
at runSingle (/var/esn/openpaas-esn/node_modules/q/q.js:137:13)
at flush (/var/esn/openpaas-esn/node_modules/q/q.js:125:13)
at _combinedTickCallback (internal/process/next_tick.js:131:7)
at process._tickCallback (internal/process/next_tick.js:180:9)

Please guide me.

Let me know if I miss anything at the time of install.

Thank You


#5

Im having a same type of issue, installed on centos 7, appreciate any help

opctl init --email admin@openpaas.local
[CLI] ERROR Command “init” returned an error: [invalid_alias_name_exception] Invalid alias name [core.events.idx], an index exists with the same name as the alias, with { index=“real.core.events.idx” } :: {“path”:"/real.core.events.idx/_alias/core.events.idx",“query”:{},“statusCode”:400,“response”:"{“error”:{“root_cause”:[{“type”:“invalid_alias_name_exception”,“reason”:“Invalid alias name [core.events.idx], an index exists with the same name as the alias”,“index”:“real.core.events.idx”}],“type”:“invalid_alias_name_exception”,“reason”:“Invalid alias name [core.events.idx], an index exists with the same name as the alias”,“index”:“real.core.events.idx”},“status”:400}"}


#6

hi,
maybe that :