Github source code setup - development environment

Hi,
I am trying to setup the latest code in a Linux (ubuntu 18.04). I am getting the below error when I try to run :slight_smile:

How do I resolve this please?
My Node version is : 10.19.0
Thanks

Hi yetiho6774
Could you give more information about it:

  • which guide you are following to install?
  • Do you using the master branch?
  • How do you run the server?

Hi @phamtuanchip

  1. which guide you are following to install?
    openpaas-esn/develop.md at master · linagora/openpaas-esn · GitHub

  2. Do you using the master branch?
    git clone https://github.com/linagora/openpaas-esn.git

  3. How do you run the server?
    I tried npm start, grunt dev & node server.js

docker ps :

Thanks for trying to help!

This is the log when I hit the url :

Could you try to catch up any other log when booting the server ?
Also any booting log when execute the docker in dev folder?
BTW I am using node v10.17.0

@phamtuanchip, you mean the output of the below command?
ESN_HOST=“172.17.0.1” ESN_PATH="$PWD" docker-compose -f ./docker/dockerfiles/dev/docker-compose.yml up

This is the log
https://pastebin.com/zxchwEVQ

This the npm start :
https://pastebin.com/e5q2SgQa

Hi @yetiho6774
Did you try to ‘npm i’ before to run the server?
Any log error when you build it?
To be sure that the hdd is free enough to run all the docker containers

  • For quick test mode
    You could try to switch to tags/1.6.2 (GA) and could be try with all in docker mode (include esn server) and execute as follow there guide steps:
    – 1) switch to tags/1.6.2
    – 2) execute: ‘PROVISION=true DOCKER_IP=172.17.0.1 docker-compose up’ in the source folder
    This should help to initialize the default data and users

  • For the development mode
    – When you run esn separately (grunt dev) not in docker, you couldn’t run ‘docker logs esn’ to get the log
    – For getting log of james you could user the ‘docker logs -f esn_james’ go show the log with correctness name of service

Hi @phamtuanchip
Yes I do have enough space.
This is the npm i ouput : root@sc-vm:~# cd openpaas-esn/root@sc-vm:~/openpaas-esn# dirDockerfile b - Pastebin.com

  • I switched to 1.6.2 and still the same issue.

– 2) execute: ‘PROVISION=true DOCKER_IP=172.17.0.1 docker-compose up’ in the source folder
This worked and http://localhost:8080 showed the open pass. But is this can be used for development purposes?. I want to use VSCode and be able to debug the source code. So i should be using grunt dev right?

I am trying the other options and paste those as well. Thanks!

npm install is :


Do I need to fix those vulnerabilities? Could that block those files?

@phamtuanchip,
All files from /components are not loading. Also I don’t see a folder called components. Is that normal?

Do you guys have any IRC chat relay please?

Thanks

Hi @yetiho6774,

It is not normal not having components directory. You could manually install frontend packages by running bower install. Hope it helps.

Hi @dtpham & @phamtuanchip
Thanks for that command it did solved that components error. Now I am able to see the login screen. When I login I get a empty screen. This is the firefox webconsole :

It is hard to say what is going on. The express server are serving all the frontend packages but the responses contain X-Content-Type-Options header which is weird.

I suggest you do a full reinstall of openpaas-esn by wiping entire node_modules and package-lock.json then running npm install again.

Hi yetiho6774,
Could you try to check the git status maybe you have been changed some relative code?

Hi @dtpham and @phamtuanchip,
Thanks for the suggestions. Deleting the modules and reinstalling solved the issue.
Thanks again!

1 Like