Getting error . Application is loading

Dear Jan_Feddersen,
Thank for your information, we could reproduce the case on the master branch, we will investigate and give you feedback soon


Please resolve the issue argrent basis … I m stuck there

please resolve the issue

Dear MEKAL,

your problem is solved ?

Dear Ashar_Khan,
The issue has been fixed, could you please try to pull new image (linagora/esn:branch-master) and start openpaas again ?
I suggest you run:

  1. docker-compose down
  2. docker system prune
  3. docker-compose pull
  4. PROVISION=true docker-compose up
    To get the rid of issue
    HTH
1 Like

Hi phamtuanchip

Now I am able to run in dev environment, as per the process given in develop.md document, but now there is another issue.

when I run server.js or grunt dev, the login screen is visible but after entering the provisioned username and password, I get a blank screen.
please see the details below, please help me resolve the issue.

after login, I get blank screen and below exception, though don.t see any error in the esn log

Hi meka,

This looks like a known issue we are having. On dev mode, some JS resources will be failed to load on Chrome. Could you try again on latest version of irefox or Chromium?

Note that, this issue only presents in dev mode. If my guess is correct, running npm start would still work fine.

Good luck!

Hi dtpham

Thanks for your reply, please tel me the remedy for this known issue , I tried npm start but getting another exceptions. screenshot is attached.

Any quick help will be good.

Have you tried on any other browser? for example Firefox

Yes I tried on firefox, still getting this error

Dear Mekal,
Could you attach the log of firefox error there ?
More question relative to:

  • which os you are using?
  • which command you execute to start the server?
  • Is the master source code you are running?

Hi phamtuanchip

Please find the details

I am running on Mac OS 10.14.6 (18G3020)

I am getting this error when i run command - “grunt dev” as well as when I run “npm start”

firefox screen shots below

I am running the master source code only

Hi All, waiting for the help in this issue.

Dear Mekal,
Could you try to rebuild the code with ‘bower install’ ?
Nearly the same issue has been posted there Application start

tried ‘bower install’ but no luck

Dear Mekal,
Could you please attach build logs and execution logs?

Dear phamtuanchip

Please find the logfiles from below links

https://drive.google.com/open?id=1F4VJrcbStvOC3kGFMWu8ocGoGkZeSvfD

https://drive.google.com/open?id=1h_5E-m00Aj6dPFlkSYCeWt3eF22p5EAv

Hi Mekal,
Could you try pull the new code from the master? We have some fix relative to provisioning the test data maybe it should be fix your issue
Otherwise , following your logs I have found some message

2020-02-24T17:12:03.455Z \cf10 error\cf2  Less compilation failed: undefined\

It maybe the root cause to be raised error
The dockerlog has none issue here.
If you did not success with new code in the master, please try to remove .node_module folder and rebuild with

npm install 

again and start the esn server as well, let us know more about the result.
Thank you.

Thanks, it worked for me