Getting error . Application is loading

Hello All

I have done with the development setup, and able to launch the application and login using user1@open-paas.org

But when I try to login with the user admin@open-paas.org I see “Application is loading” message and below this message “We encountered a problem to load the application:” for your reference I am attaching the screen shots and logs, please help me on this.!

38%20PM|690x312

Dear Mekal
Could you please try to provide the log of docker, ens server ?

  • docker ps
  • docker esn logs
    should be nice to catch some more information
    HTH

I have the same problem.
Here are the outputs:

docker ps

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
e036d6e0e728 linagora/james-project:branch-master “bash -c 'java -Dlog…” 8 seconds ago Up 6 seconds 4000/tcp, 0.0.0.0:8000->8000/tcp, 0.0.0.0:1025->25/tcp, 0.0.0.0:1080->80/tcp, 0.0.0.0:1110->110/tcp, 0.0.0.0:1143->143/tcp, 0.0.0.0:1465->465/tcp, 0.0.0.0:1587->587/tcp, 0.0.0.0:1993->993/tcp esn_james
1a89c986ff38 linagora/esn:branch-master “docker-entrypoint.s…” 10 seconds ago Up 8 seconds 0.0.0.0:8081->8080/tcp esn
05b92ff8421c linagora/esn-sabre:branch-master “sh ./scripts/start.…” 13 seconds ago Up 10 seconds 0.0.0.0:8001->80/tcp esn_sabre
f5da791c5b41 rabbitmq:3.6.5-management “docker-entrypoint.s…” 18 seconds ago Up 12 seconds 4369/tcp, 5671/tcp, 0.0.0.0:5672->5672/tcp, 15671/tcp, 25672/tcp, 0.0.0.0:15672->15672/tcp esn_rabbitmq
cf7cc7814363 mongo:3.2 “docker-entrypoint.s…” 18 seconds ago Up 13 seconds 0.0.0.0:27017->27017/tcp esn_mongo
7e8dd1622c53 cassandra:3.11.3 “docker-entrypoint.s…” 18 seconds ago Up 14 seconds 7000-7001/tcp, 7199/tcp, 9160/tcp, 0.0.0.0:9042->9042/tcp esn_cassandra
3c9d7f4cab49 docker.elastic.co/elasticsearch/elasticsearch:6.3.2 “/usr/local/bin/dock…” 18 seconds ago Up 16 seconds 0.0.0.0:9200->9200/tcp, 9300/tcp esn_elasticsearch
066c7b1b4345 redis:latest “docker-entrypoint.s…” 18 seconds ago Up 17 seconds 0.0.0.0:6379->6379/tcp esn_redis

docker logs esn

the output is too long, but the only error is:
[CLI] ERROR { MongoError: E11000 duplicate key error collection: esn_docker.users index: accounts.emails_1 dup key: { : "admin@open-paas.org" }
at Function.create (/var/www/node_modules/mongodb-core/lib/error.js:43:12)
at toError (/var/www/node_modules/mongoose/node_modules/mongodb/lib/utils.js:149:22)
at coll.s.topology.insert (/var/www/node_modules/mongoose/node_modules/mongodb/lib/operations/collection_ops.js:859:39)
at /var/www/node_modules/mongodb-core/lib/connection/pool.js:397:18
at process._tickCallback (internal/process/next_tick.js:61:11)
driver: true,
name: ‘MongoError’,
index: 0,
code: 11000,
errmsg:
‘E11000 duplicate key error collection: esn_docker.users index: accounts.emails_1 dup key: { : "admin@open-paas.org" }’,
[Symbol(mongoErrorContextSymbol)]: {} }
2019-11-27T20:25:34.377Z e[34mdebuge[39m local/SUBSCRIBE to: amqp:disconnected
2019-11-27T20:25:34.380Z e[34mdebuge[39m local/SUBSCRIBE to: amqp:client:available
2019-11-27T20:25:34.380Z e[34mdebuge[39m local/SUBSCRIBE to: mongodb:connectionAvailable
Connected to MongoDB at mongodb://mongo:27017/esn_docker
Disconnecting from MongoDB
[CLI] ERROR Error: There is already platformadmin in the system, use --force to overwrite
at verify.then.isAllowed (/var/www/bin/commands/platformadmin_cmds/init.js:57:21)
at _fulfilled (/var/www/node_modules/q/q.js:854:54)
at /var/www/node_modules/q/q.js:883:30
at Promise.promise.promiseDispatch (/var/www/node_modules/q/q.js:816:13)
at /var/www/node_modules/q/q.js:624:44
at runSingle (/var/www/node_modules/q/q.js:137:13)
at flush (/var/www/node_modules/q/q.js:125:13)
at process._tickCallback (internal/process/next_tick.js:61:11)
Starting OpenPaaS ESN

Dear morphiumdeus
Could you please attach the docker compose file to execute ?
Which command do you use to start the docker container ?

I’ve done this from the instructions:

git clone https://github.com/linagora/openpaas-esn.git

and then

cd openpaas-esn
PROVISION=true docker-compose up

Same here.

If you follow the instructions, using the defaul docker compose it fails to load !

I’ve done this from the instructions:

git clone https://github.com/linagora/openpaas-esn.git

and then
cd openpaas-esn
PROVISION=true docker-compose up

also

if you follow:

this is not possible as /docker/dockerfiles/platform/docker-compose.yml is not existing
replacing it with /docker/dockerfiles/dev/docker-compose.yml creates an environment but is not able to connect to it.

I only use unchanded defaults.

Dear Jan_Feddersen,
Thank for your information, we could reproduce the case on the master branch, we will investigate and give you feedback soon


Please resolve the issue argrent basis … I m stuck there

please resolve the issue

Dear MEKAL,

your problem is solved ?

Dear Ashar_Khan,
The issue has been fixed, could you please try to pull new image (linagora/esn:branch-master) and start openpaas again ?
I suggest you run:

  1. docker-compose down
  2. docker system prune
  3. docker-compose pull
  4. PROVISION=true docker-compose up
    To get the rid of issue
    HTH
1 Like

Hi phamtuanchip

Now I am able to run in dev environment, as per the process given in develop.md document, but now there is another issue.

when I run server.js or grunt dev, the login screen is visible but after entering the provisioned username and password, I get a blank screen.
please see the details below, please help me resolve the issue.

after login, I get blank screen and below exception, though don.t see any error in the esn log

Hi meka,

This looks like a known issue we are having. On dev mode, some JS resources will be failed to load on Chrome. Could you try again on latest version of irefox or Chromium?

Note that, this issue only presents in dev mode. If my guess is correct, running npm start would still work fine.

Good luck!

Hi dtpham

Thanks for your reply, please tel me the remedy for this known issue , I tried npm start but getting another exceptions. screenshot is attached.

Any quick help will be good.

Have you tried on any other browser? for example Firefox

Yes I tried on firefox, still getting this error

Dear Mekal,
Could you attach the log of firefox error there ?
More question relative to:

  • which os you are using?
  • which command you execute to start the server?
  • Is the master source code you are running?

Hi phamtuanchip

Please find the details

I am running on Mac OS 10.14.6 (18G3020)

I am getting this error when i run command - “grunt dev” as well as when I run “npm start”

firefox screen shots below

I am running the master source code only

Hi All, waiting for the help in this issue.