Comment configurer le smtp et pop de openpaas?


#1

Bonjour,
je suis à la recherche de solution pour remplacer exchange 2010, nous avons 1500 mails environs. openpaas me parait une solution viable, je suis en train de le tester, mais lors de l’installation je rencontre beaucoup de problème pour le paramétrage. je ne trouve pas beaucoup de tutos pour m’aider.
j’ai installer openpaas sur un debians 8.11, la partie serveur fonctionne bien, je suis maintenant sur la partie web.
je voudrais configurer correctement mon openpaas pour recevoir et envoyer mes mails, comment dois je faire?
il y a t-il d’autres info à paramétrer?
Existe t-il des tutos?

merci d’avance pour vos aides.

Chan


#2

Bonjour Chan,

Quelle installation vous avez suivi ?
Vous utilisez quoi comme mail serveur ? Apache James ? ou autre ?

Cordialement,
Aymane.


#3

Bonjour,

J’ai suivi l’installation sous debians 8.11 :
http://docs.open-paas.org/getting-started/linux/
voici le lien

oui sur apache James


#4

Connecte toi sur l’utilisateurs qui est le administrateur du domaine,
Quelle est ta configurations dans l’onglet Mail ?


#5

Hi,
I too trying to figure out, how to enable James(SMTP)

After installation I connected to OpenPaas Webportal as administrator, and specify localhost DNS(mail.domain.com) as smtp server, even restarted all service that listed in documenation
systemctl restart {mongod,elasticsearch,cassandra,redis,rabbitmq-server,php-fpm,nginx,james,openpaas}
But SMTP seems not enabled and I am not able to access James webadmin portal.

Please help
Thanks
Daniel


#6

voici ma configuration sur le mail :
transport type = SMTP
Host = smtp.cd61.fr
port =25


How to config mailbox openpaas?
#7

Thanks for the reply, I too configured same way. Openpaas server and james server are running on same server. However after putting those entry it not accepting any mail, even when I am checking smtp port on server (25) i can’t see it is opened. I tried “telnet localhost 25” and does not connect.

Am I missing something here?

Kind regards,
Daniel


#8

Hi,
I’m not sure about the problem.
Please go to the file /root/conf/logback.xml to find the path of log file (the value of <file> tag)?
Please check the log or transfer it to me.
Thanks.


#9

hi,
the directory /root/conf do not exist
but i have 2 files on /etc/james and /etc/cassaandra

on James :

<?xml version="1.0" encoding="UTF-8"?>
    <contextListener class="ch.qos.logback.classic.jul.LevelChangePropagator">
            <resetJUL>true</resetJUL>
    </contextListener>

    <appender name="LOG_FILE" class="ch.qos.logback.core.rolling.RollingFileAppe$
            <file>/var/log/james/james.log</file>

            <rollingPolicy class="ch.qos.logback.core.rolling.SizeAndTimeBasedRo$
                    <!-- daily rollover -->
                    <fileNamePattern>logFile.%d{yyyy-MM-dd}.%i.log</fileNamePatt$
                    <maxFileSize>100MB</maxFileSize>
                    <maxHistory>29</maxHistory>
                    <totalSizeCap>2GB</totalSizeCap>
            </rollingPolicy>

            <encoder>
                    <pattern>%d{HH:mm:ss.SSS} [%-5level] %logger{15} - %msg%n%rE$
                    <immediateFlush>false</immediateFlush>
            </encoder>
    </appender>

    <logger name="http.jmap" level="DEBUG" />

    <root level="INFO">
            <appender-ref ref="LOG_FILE" />
    </root>

on cassandra :

${cassandra.logdir}/system.log
${cassandra.logdir}/debug.log


#10

hi,
Please take the file log in
<file>/var/log/james/james.log</file>
Thanks


#11

Hi,
In my case /var/log/james/james.log is empty.
OS and package versions
CentOS7.5
openpaas-james-1.2.2-1.el7.x86_64
james-3.2.0_SNAPSHOT_openpaas_1.2.2-1.x86_64
openpaas-1.2.2-1.el7.x86_64
openpaas-davserver-1.2.2-1.el7.x86_64

I assume that as and when we add domain and SMTP port api will invoke james and activate smtp port and domain, am I correct? or missing something?

Thanks,
Binoy


#12

Hi,
Please run:
dpkg -l | grep -E 'openpaas|jame|cassandra'
and then show me the result of it.
I think we have some conflicts in James configuration.

Thanks.


#13

Please find details about package information.

[root@openpaas ~]# rpm -qa |grep mongod
mongodb-org-tools-3.4.18-1.el7.x86_64
php-pecl-mongodb-1.5.3-1.el7.remi.7.0.x86_64
mongodb-org-3.4.18-1.el7.x86_64
mongodb-org-server-3.4.18-1.el7.x86_64
mongodb-org-shell-3.4.18-1.el7.x86_64
mongodb-org-mongos-3.4.18-1.el7.x86_64
[root@openpaas ~]# rpm -qa |grep elasticsearch
elasticsearch-2.4.6-1.noarch
[root@openpaas ~]# rpm -qa |grep cassandra
cassandra22-2.2.8-1.noarch
[root@openpaas ~]# rpm -qa |grep redis
redis-5.0.1-1.el7.remi.x86_64
[root@openpaas ~]# rpm -qa |grep rabbitmq-server
rabbitmq-server-3.3.5-34.el7.noarch
[root@openpaas ~]# rpm -qa |grep nginx
nginx-mod-http-geoip-1.12.2-2.el7.x86_64
nginx-1.12.2-2.el7.x86_64
nginx-mod-http-image-filter-1.12.2-2.el7.x86_64
nginx-mod-http-xslt-filter-1.12.2-2.el7.x86_64
nginx-mod-mail-1.12.2-2.el7.x86_64
nginx-mod-http-perl-1.12.2-2.el7.x86_64
nginx-filesystem-1.12.2-2.el7.noarch
nginx-mod-stream-1.12.2-2.el7.x86_64
nginx-all-modules-1.12.2-2.el7.noarch
[root@openpaas ~]# rpm -qa |grep james
openpaas-james-1.2.2-1.el7.x86_64
james-3.2.0_SNAPSHOT_openpaas_1.2.2-1.x86_64
[root@openpaas ~]# rpm -qa |grep openpaas
openpaas-james-1.2.2-1.el7.x86_64
james-3.2.0_SNAPSHOT_openpaas_1.2.2-1.x86_64
openpaas-1.2.2-1.el7.x86_64
openpaas-davserver-1.2.2-1.el7.x86_64


#14

hi,
i have this information with this commande :

root@openpaas:~# dpkg -l | grep -E ‘openpaas|jame|cassandra’
ii cassandra 2.2.13 all distributed storage system for structured data
ii james 3.2.0-SNAPSHOT-openpaas-1.2.2-1 amd64 James stands for Java Apache Mail Enterprise Server!
ii openpaas 1.2.2-1+jessie amd64 OpenPaas Enterprise Social Network - Application Server
ii openpaas-davserver 1.2.2-1+jessie amd64 OpenPaas Enterprise Social Network - *DAV Server
ii openpaas-james 1.2.2-1+jessie amd64 OpenPaas Enterprise Social Network - Apache James configuration files for OpenPaaS
root@openpaas:~#


#15

Hi @chan and @binoyda,
I found the root cause of this problem.
James-3.2.0 depend on the cassandra 311x but in get.open-paas.org cassandra is
addDebianRepository cassandra "deb http://www.apache.org/dist/cassandra/debian 22x main".
Please follow the Upgrade proceduce https://github.com/linagora/james-project/blob/master/upgrade-instructions.md#cassandra-3113-upgrade from James teams.
Thanks.


#16

it is ok now?

root@openpaas:~# dpkg -l | grep -E ‘openpaas|jame|cassandra’
ii cassandra 3.11.3 all distributed storage system for structured data
ii james 3.2.0-SNAPSHOT-openpaas-1.2.2-1 amd64 James stands for Java Apache Mail Enterprise Server!
ii openpaas 1.2.2-1+jessie amd64 OpenPaas Enterprise Social Network - Application Server
ii openpaas-davserver 1.2.2-1+jessie amd64 OpenPaas Enterprise Social Network - *DAV Server
ii openpaas-james 1.2.2-1+jessie amd64 OpenPaas Enterprise Social Network - Apache James configuration files for OpenPaaS


#17

i have that, i don’t know why i can’t to connect to James server :slight_smile:


#18

Hi,
Can you show me
systemctl status james
Thanks


#19

hi.

root@openpaas:~# systemctl status james
● james.service - James stands for Java Apache Mail Enterprise Server! It has a
Loaded: loaded (/lib/systemd/system/james.service; enabled; vendor preset: en
Active: active (running) since ven. 2018-11-30 11:05:45 CET; 2 days ago
Docs: http://james.apache.org
Main PID: 2330 (java)
CGroup: /system.slice/james.service
└─2330 /usr/lib/jvm/java-8-openjdk-amd64/bin/java -Dworking.directory

Warning: Journal has been rotated since unit was started. Log output is incomple


#20

hi,
Please show me all the log output.
I need to verify what error occurred
Thanks